What’s Vulnerable › Vulnerabilities
CVE-2024-13155: Unlimited Elements For Elementor (Free Widgets, Addons, Templates) <= 1.5.140 - Authenticated (Contributor+) Stored Cross-Site Scripting via Transparent Split Hero Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Unlimited Elements For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Transparent Split Hero widget in all versions up to, and including, 1.5.140 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: Since the widget code isn't part of the code base, to apply the patch, the affected widget: Transparent Split Hero must be deleted and reinstalled manually.
Affected products
- unitecms Unlimited Elements For Elementor: before 1.5.141 — fixed in 1.5.141
How to fix
Upgrade to a fixed version: unitecms Unlimited Elements For Elementor 1.5.141. Check the vendor advisory for mitigations.
References
- https://unlimited-elements.com/change-log/
- https://wordpress.org/plugins/unlimited-elements-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/63ba4880-9fbb-42e3-a8db-8115eb832b13?source=cve
Get alerted when CVE-2024-13155 or the next vulnerability affects your stack