What’s Vulnerable › Vulnerabilities
CVE-2024-13230: Social Share, Social Login and Social Comments Plugin – Super Socializer <= 7.14 - Unauthenticated Limited SQL Injection via 'SuperSocializerKey'
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-21 · updated 2026-06-17
- Weakness: CWE-89
Description
The Social Share, Social Login and Social Comments Plugin – Super Socializer plugin for WordPress is vulnerable to Limited SQL Injection via the ‘SuperSocializerKey’ parameter in all versions up to, and including, 7.14 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional values into the already existing query that can be used to extract user metadata from the database.
Affected products
- the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer: before 7.14.1 — fixed in 7.14.1
How to fix
Upgrade to a fixed version: the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer 7.14.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/super-socializer/trunk/super_socializer.php#L291
- https://plugins.trac.wordpress.org/changeset/3225440/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4d7b2a7f-3c67-4df1-bb15-e7f4f0035953?source=cve
Get alerted when CVE-2024-13230 or the next vulnerability affects your stack