What’s Vulnerable › Vulnerabilities
CVE-2024-13239: Two-factor Authentication (TFA) - Moderately critical - Access bypass - SA-CONTRIB-2024-003
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-1390
Description
Weak Authentication vulnerability in Drupal Two-factor Authentication (TFA) allows Authentication Abuse.This issue affects Two-factor Authentication (TFA): from 0.0.0 before 1.5.0.
Affected products
- Drupal Two-factor Authentication (TFA): before 8.x-1.5 — fixed in 8.x-1.5
How to fix
Upgrade to a fixed version: Drupal Two-factor Authentication (TFA) 8.x-1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13239 or the next vulnerability affects your stack