What’s Vulnerable › Vulnerabilities
CVE-2024-13258: Drupal REST & JSON API Authentication - Moderately critical - Access bypass - SA-CONTRIB-2024-022
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Drupal Drupal REST & JSON API Authentication allows Forceful Browsing.This issue affects Drupal REST & JSON API Authentication: from 0.0.0 before 2.0.13.
Affected products
- Drupal REST & JSON API Authentication: before 2.0.13 — fixed in 2.0.13
How to fix
Upgrade to a fixed version: Drupal REST & JSON API Authentication 2.0.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13258 or the next vulnerability affects your stack