What’s Vulnerable › Vulnerabilities
CVE-2024-13273: Open Social - Moderately critical - Cross Site Scripting, Denial of Service - SA-CONTRIB-2024-037
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Open Social allows Cross-Site Scripting (XSS).This issue affects Open Social: from 0.0.0 before 12.3.8, from 12.4.0 before 12.4.5, from 13.0.0 before 13.0.0-alpha11.
Affected products
- Drupal Open Social: before 12.3.8; from 12.4.0 before 12.4.5; 13.0.0-alpha1, 13.0.0-alpha10, 13.0.0-alpha2, 13.0.0-alpha3, 13.0.0-alpha4, 13.0.0-alpha5 (+4) — fixed in 12.3.8, 12.4.5
How to fix
Upgrade to a fixed version: Drupal Open Social 12.3.8, 12.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13273 or the next vulnerability affects your stack