What’s Vulnerable › Vulnerabilities

CVE-2024-1329: Nomad Vulnerable to Arbitrary Write Through Symlink Attack

Description

HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.

Affected products

How to fix

Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.5.14, 1.6.7, 1.7.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-1329 or the next vulnerability affects your stack