What’s Vulnerable › Vulnerabilities
CVE-2024-1330: Kadence Blocks Pro < 2.3.8 - Contributor+ Arbitrary Option Access
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-27 · updated 2026-06-17
Description
The kadence-blocks-pro WordPress plugin before 2.3.8 does not prevent users with at least the contributor role using some of its shortcode's functionalities to leak arbitrary options from the database.
Affected products
- kadence-blocks-pro: before 2.3.8 — fixed in 2.3.8
How to fix
Upgrade to a fixed version: kadence-blocks-pro 2.3.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1988815b-7a53-4657-9b1c-1f83c9f9ccfd/
- https://wpscan.com/vulnerability/1988815b-7a53-4657-9b1c-1f83c9f9ccfd/
Get alerted when CVE-2024-1330 or the next vulnerability affects your stack