What’s Vulnerable › Vulnerabilities
CVE-2024-13301: OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) - Critical - Cross Site Scripting - SA-CONTRIB-2024-067
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) allows Cross-Site Scripting (XSS).This issue affects OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client): from 3.0.0 before 3.44.0, from 4.0.0 before 4.0.19.
Affected products
- Drupal OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client): from 3.0.0 before 3.44.0; from 4.0.0 before 4.0.19 — fixed in 3.44.0, 4.0.19
How to fix
Upgrade to a fixed version: Drupal OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) 3.44.0, 4.0.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13301 or the next vulnerability affects your stack