What’s Vulnerable › Vulnerabilities
CVE-2024-13315: Shopwarden – Automated WooCommerce monitoring & testing <= 1.0.11 - Cross-Site Request Forgery to Arbitrary Options Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The Shopwarden – Automated WooCommerce monitoring & testing plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.11. This is due to missing or incorrect nonce validation on the save_setting() function. This makes it possible for unauthenticated attackers to update arbitrary options and achieve privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Shopwarden – Automated WooCommerce monitoring & testing: before 1.0.12 — fixed in 1.0.12
How to fix
Upgrade to a fixed version: Shopwarden – Automated WooCommerce monitoring & testing 1.0.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/shopwarden/trunk/shopwarden.php#L112
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3238978%40shopwarden&new=3238978%40shopwarden&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b11ed628-f736-4262-80a2-62b32948a3a4?source=cve
Get alerted when CVE-2024-13315 or the next vulnerability affects your stack