What’s Vulnerable › Vulnerabilities
CVE-2024-13319: Themify Builder <= 7.6.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Themify Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 7.6.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Themify Builder: before 7.6.6 — fixed in 7.6.6
How to fix
Upgrade to a fixed version: Themify Builder 7.6.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3224684/themify-builder/trunk/themify/themify-admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/69ac1e37-4e31-4dce-a2d6-07a4299995c5?source=cve
Get alerted when CVE-2024-13319 or the next vulnerability affects your stack