What’s Vulnerable › Vulnerabilities
CVE-2024-13321: AnalyticsWP <= 2.0.0 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-14 · updated 2026-06-17
- Weakness: CWE-89
Description
The AnalyticsWP plugin for WordPress is vulnerable to SQL Injection via the 'custom_sql' parameter in all versions up to, and including, 2.0.0 due to insufficient authorization checks on the handle_get_stats() function. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- Solid Plugins AnalyticsWP: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: Solid Plugins AnalyticsWP 2.1.0. Check the vendor advisory for mitigations.
References
- https://analyticswp.com/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f6507318-92c0-457c-8c87-2d023428a77f?source=cve
Get alerted when CVE-2024-13321 or the next vulnerability affects your stack