What’s Vulnerable › Vulnerabilities
CVE-2024-13323: Booking Calendar <= 10.9.2 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via 'booking' Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Booking Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'booking' shortcode in all versions up to, and including, 10.9.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpdevelop Booking Calendar: before 10.9.3 — fixed in 10.9.3
How to fix
Upgrade to a fixed version: wpdevelop Booking Calendar 10.9.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/booking/trunk/js/client.js#L270
- https://plugins.trac.wordpress.org/changeset/3220625/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/37731e51-33ce-4ef3-8a13-976c005dc983?source=cve
Get alerted when CVE-2024-13323 or the next vulnerability affects your stack