What’s Vulnerable › Vulnerabilities
CVE-2024-1333: Responsive Pricing Table < 5.1.11 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Pricing Table WordPress plugin before 5.1.11 does not validate and escape some of its Pricing Table options before outputting them back in a page/post where the related shortcode is embed, which could allow users with the author role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Responsive Pricing Table: before 5.1.11 — fixed in 5.1.11
How to fix
Upgrade to a fixed version: Responsive Pricing Table 5.1.11. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/30546402-03b8-4e18-ad7e-04a6b556ffd7/
- https://wpscan.com/vulnerability/30546402-03b8-4e18-ad7e-04a6b556ffd7/
Get alerted when CVE-2024-1333 or the next vulnerability affects your stack