What’s Vulnerable › Vulnerabilities
CVE-2024-13337: Webcraftic Clearfy – WordPress optimization plugin <= 2.3.2 - Cross-Site Request Forgery to Plugin Settings Update via 'setup-wbcr_clearfy'
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3.2. This is due to missing or incorrect nonce validation on the 'setup-wbcr_clearfy' page. This makes it possible for unauthenticated attackers to update the plugins settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- creativemotion Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: creativemotion Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer 2.3.3. Check the vendor advisory for mitigations.
References
- https://github.dev/WordPressPluginDirectory/clearfy
- https://plugins.trac.wordpress.org/changeset/3268278/clearfy/trunk/libs/factory/templates/pages/setup-parts/class-step-form.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d7f21dbe-f300-4336-9980-a69d40395f39?source=cve
Get alerted when CVE-2024-13337 or the next vulnerability affects your stack