What’s Vulnerable › Vulnerabilities
CVE-2024-13338: Webcraftic Clearfy – WordPress optimization plugin <= 2.3.1 - Cross-Site Request Forgery to Clear Cache
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3.1. This is due to missing or incorrect nonce validation on the wclearfy_cache_delete functionality . This makes it possible for unauthenticated attackers to clear the cache via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- creativemotion Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: creativemotion Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer 2.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3268278/clearfy/trunk/components/cache/includes/cache.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e0a37ce4-9860-415e-bb88-545c30c95fc1?source=cve
Get alerted when CVE-2024-13338 or the next vulnerability affects your stack