What’s Vulnerable › Vulnerabilities
CVE-2024-13342: Booster for WooCommerce <= 7.2.4 - Unauthenticated Double Extension Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-09-26
- Weakness: CWE-434
Description
The Booster for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'add_files_to_order' function in all versions up to, and including, 7.2.4. This makes it possible for unauthenticated attackers to upload arbitrary files with double extensions on the affected site's server which may make remote code execution possible. This is only exploitable on select instances where the configuration will execute the first extension present.
Affected products
- pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools: before 7.2.5 — fixed in 7.2.5
How to fix
Upgrade to a fixed version: pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools 7.2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woocommerce-jetpack/tags/7.2.4/includes/class-wcj-checkout-files-upload.php#L452
- https://plugins.trac.wordpress.org/changeset/3262569/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5ac8a125-121c-4392-846e-625726043972?source=cve
Get alerted when CVE-2024-13342 or the next vulnerability affects your stack