What’s Vulnerable › Vulnerabilities
CVE-2024-13343: WooCommerce Customers Manager <= 31.3 - Missing Authorization to Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-01 · updated 2026-06-17
- Weakness: CWE-269
Description
The WooCommerce Customers Manager plugin for WordPress is vulnerable to Privilege Escalation due to a missing capability check on the ajax_assign_new_roles() function in all versions up to, and including, 31.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges to that of an administrator.
Affected products
- WooCommerce Customers Manager: before 31.4 — fixed in 31.4
How to fix
Upgrade to a fixed version: WooCommerce Customers Manager 31.4. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/woocommerce-customers-manager/10965432
- https://www.wordfence.com/threat-intel/vulnerabilities/id/193c9fe9-17bc-47e7-b93d-dfcebcf8004d?source=cve
Get alerted when CVE-2024-13343 or the next vulnerability affects your stack