What’s Vulnerable › Vulnerabilities
CVE-2024-13344: Advance Seat Reservation Management for WooCommerce <= 3.3 - Unauthenticated SQL Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-89
Description
The Advance Seat Reservation Management for WooCommerce plugin for WordPress is vulnerable to SQL Injection via the 'profileId' parameter in all versions up to, and including, 3.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- smartcms Advance Seat Reservation Management for WooCommerce: before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: smartcms Advance Seat Reservation Management for WooCommerce 3.4. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/advance-seat-reservation-management-for-woocommerce/19984266
- https://www.wordfence.com/threat-intel/vulnerabilities/id/35acdb85-e463-46b1-aea7-a6d4c3581499?source=cve
Get alerted when CVE-2024-13344 or the next vulnerability affects your stack