What’s Vulnerable › Vulnerabilities
CVE-2024-13349: Stockdio Historical Chart <= 2.8.18 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Stockdio Historical Chart plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'stockdio-historical-chart' shortcode in all versions up to, and including, 2.8.18 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Stockdio Historical Chart: before 2.8.19 — fixed in 2.8.19
How to fix
Upgrade to a fixed version: Stockdio Historical Chart 2.8.19. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/stockdio-historical-chart/trunk/stockdioplugin.php#L1155
- https://plugins.trac.wordpress.org/changeset/3231386/
- https://wordpress.org/plugins/stockdio-historical-chart
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ecf476a8-e341-44d4-988c-a7fb3fb538d1?source=cve
Get alerted when CVE-2024-13349 or the next vulnerability affects your stack