What’s Vulnerable › Vulnerabilities
CVE-2024-13356: DSGVO All in one for WP <= 4.6 - Cross-Site Request Forgery to Account Deletion
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-352
Description
The DSGVO All in one for WP plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.6. This is due to missing or incorrect nonce validation in the user_remove_form.php file. This makes it possible for unauthenticated attackers to delete admin user accounts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Michael Leithold DSGVO All in one for WP: before 4.7 — fixed in 4.7
How to fix
Upgrade to a fixed version: Michael Leithold DSGVO All in one for WP 4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/dsgvo-all-in-one-for-wp/trunk/core/inc/user_remove_form.php#L25
- https://plugins.trac.wordpress.org/changeset/3233492/dsgvo-all-in-one-for-wp/trunk/core/inc/user_remove_form.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2efe885d-7e17-4057-abde-37482047facb?source=cve
Get alerted when CVE-2024-13356 or the next vulnerability affects your stack