What’s Vulnerable › Vulnerabilities
CVE-2024-13357: Ditty – Responsive News Tickers, Sliders, and Lists < 3.1.52 - Author+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ditty WordPress plugin before 3.1.52 does not sanitise and escape some of its settings, which could allow high privilege users such as author to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Ditty: before 3.1.52 — fixed in 3.1.52
How to fix
Upgrade to a fixed version: Ditty 3.1.52. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d134bb34-6324-4bc8-943e-4e743d00fcb2/
- https://wpscan.com/vulnerability/d134bb34-6324-4bc8-943e-4e743d00fcb2/
Get alerted when CVE-2024-13357 or the next vulnerability affects your stack