What’s Vulnerable › Vulnerabilities
CVE-2024-13358: BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages <= 3.4.24 - Missing Authorization to Authenticated (Subscriber+) Limited Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-01 · updated 2026-06-17
- Weakness: CWE-862
Description
The BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the wc4bp_delete_page() function in all versions up to, and including, 3.4.24. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugins page setting.
Affected products
- themekraft BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages: before 3.4.25 — fixed in 3.4.25
How to fix
Upgrade to a fixed version: themekraft BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages 3.4.25. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3244145%40wc4bp&new=3244145%40wc4bp&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2f526f3c-4e9b-4440-b3c3-8541c1be0ba0?source=cve
Get alerted when CVE-2024-13358 or the next vulnerability affects your stack