What’s Vulnerable › Vulnerabilities
CVE-2024-13360: AI Power: Complete AI Pack <= 1.8.96 - Authenticated (Subscriber+) Server-Side Request Forgery
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-918
Description
The AI Power: Complete AI Pack plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.8.96 via the wpaicg_troubleshoot_add_vector(). This makes it possible for authenticated attackers, with subscriber-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- senols AI Puffer – Your AI engine for WordPress (formerly AI Power): before 1.8.97 — fixed in 1.8.97
How to fix
Upgrade to a fixed version: senols AI Puffer – Your AI engine for WordPress (formerly AI Power) 1.8.97. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3224162/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5cf6cbba-0e0c-4d2c-90d0-d7e0a5222df2?source=cve
Get alerted when CVE-2024-13360 or the next vulnerability affects your stack