What’s Vulnerable › Vulnerabilities
CVE-2024-13361: AI Power: Complete AI Pack <= 1.8.96 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Shortcode Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-862
Description
The AI Power: Complete AI Pack plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the wpaicg_save_image_media function in all versions up to, and including, 1.8.96. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload image files and embed shortcode attributes in the image_alt value that will execute when sending a POST request to the attachment page.
Affected products
- senols AI Puffer – Your AI engine for WordPress (formerly AI Power): before 1.8.97 — fixed in 1.8.97
How to fix
Upgrade to a fixed version: senols AI Puffer – Your AI engine for WordPress (formerly AI Power) 1.8.97. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3224162/gpt3-ai-content-generator/trunk/classes/wpaicg_image.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/11d49c89-43be-4e12-86b5-aa7a72a89803?source=cve
Get alerted when CVE-2024-13361 or the next vulnerability affects your stack