What’s Vulnerable › Vulnerabilities
CVE-2024-1337: SKT Page Builder <= 4.1 - Missing Authorization to Authenticated(Subscriber+) Content Injection
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-862
Description
The SKT Page Builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'saveSktbuilderPageData' function in all versions up to, and including, 4.1. This makes it possible for authenticated attackers, with subscriber access and above, to inject arbitrary content into pages.
Affected products
- sonalsinha21 SKT Page Builder: before 4.2 — fixed in 4.2
How to fix
Upgrade to a fixed version: sonalsinha21 SKT Page Builder 4.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3034383/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3164b96f-d876-4cbc-bddf-51e9d9becee6?source=cve
- https://plugins.trac.wordpress.org/changeset/3034383/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3164b96f-d876-4cbc-bddf-51e9d9becee6?source=cve
Get alerted when CVE-2024-1337 or the next vulnerability affects your stack