What’s Vulnerable › Vulnerabilities
CVE-2024-13402: BuddyBoss Platform <= 2.7.70 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'link_title'
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Buddyboss Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘link_title’ parameter in all versions up to, and including, 2.7.70 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Boss Media BuddyBoss Platform: before 2.8.00 — fixed in 2.8.00
How to fix
Upgrade to a fixed version: Boss Media BuddyBoss Platform 2.8.00. Check the vendor advisory for mitigations.
References
- https://www.buddyboss.com/resources/buddyboss-platform-releases/2-8-00/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/42743c2f-053b-4f14-bf11-865f978ec017?source=cve
Get alerted when CVE-2024-13402 or the next vulnerability affects your stack