What’s Vulnerable › Vulnerabilities
CVE-2024-13407: Omnipress <= 1.5.4 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-14 · updated 2026-06-17
- Weakness: CWE-639
Description
The Omnipress plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.5.4 via the megamenu block due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, or draft posts that they should not have access to.
Affected products
- omnipressteam Omnipress: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: omnipressteam Omnipress 1.5.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3254484/omnipress/trunk/includes/Blocks/BlockTypes/Megamenu.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fa17f78a-5e4a-441e-bbbb-d13bad648c39?source=cve
Get alerted when CVE-2024-13407 or the next vulnerability affects your stack