What’s Vulnerable › Vulnerabilities
CVE-2024-13409: Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor Widget <= 1.6.10 - Authenticated (Contributor+) Local File Inclusion via post_type_ajax_handler()
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-24 · updated 2026-06-17
- Weakness: CWE-22
Description
The Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor Widget plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.6.10 via the 'theme' parameter of the post_type_ajax_handler() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
Affected products
- wpwax Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor Widget: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: wpwax Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor Widget 1.7. Check the vendor advisory for mitigations.
References
- https://ja.wordpress.org/plugins/post-grid-carousel-ultimate/
- https://plugins.trac.wordpress.org/browser/post-grid-carousel-ultimate/tags/1.6.10/includes/classes/ajax.php
- https://plugins.trac.wordpress.org/changeset/3227281/post-grid-carousel-ultimate/tags/1.7/includes/classes/ajax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/38672a45-b7a7-445f-9e77-7050df6920fa?source=cve
Get alerted when CVE-2024-13409 or the next vulnerability affects your stack