What’s Vulnerable › Vulnerabilities
CVE-2024-13430: Page Builder: Pagelayer – Drag and Drop website builder <= 1.9.8 - Authenticated (Contributor+) Private Post Disclosure in pagelayer_builder_posts_shortcode
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-284
Description
The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.9.8 via the 'pagelayer_builder_posts_shortcode' function due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private posts that they should not have access to.
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.9.9 — fixed in 1.9.9
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.9.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3252081/pagelayer
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1de8da4c-dee7-4d59-a475-a969008aa0d4?source=cve
Get alerted when CVE-2024-13430 or the next vulnerability affects your stack