What’s Vulnerable › Vulnerabilities
CVE-2024-13431: Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin <= 1.6.8.3 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the accent_color and background parameter in all versions up to, and including, 1.6.8.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- NSquared Appointment Booking Calendar: before 1.6.8.5 — fixed in 1.6.8.5
How to fix
Upgrade to a fixed version: NSquared Appointment Booking Calendar 1.6.8.5. Check the vendor advisory for mitigations.
References
- https://blog.lucianohanna.com.br/security/cve/cve-2024-13431-reflected-xss-no-simply-schedule-appointments/
- https://plugins.trac.wordpress.org/browser/simply-schedule-appointments/tags/1.6.8.3/booking-app-new/iframe-inner.php#L182
- https://plugins.trac.wordpress.org/browser/simply-schedule-appointments/tags/1.6.8.3/includes/class-styles.php#L116
- https://plugins.trac.wordpress.org/browser/simply-schedule-appointments/tags/1.6.8.3/includes/class-styles.php#L97
- https://plugins.trac.wordpress.org/changeset/3246760/simply-schedule-appointments/trunk/booking-app-new/iframe-inner.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f6e3e5dd-b9f1-4d24-98cc-b6ab319434e4?source=cve
Get alerted when CVE-2024-13431 or the next vulnerability affects your stack