What’s Vulnerable › Vulnerabilities
CVE-2024-13438: SpeedSize Image & Video AI-Optimizer <= 1.5.1 - Cross-Site Request Forgery to Clear Cache
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The SpeedSize Image & Video AI-Optimizer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.5.1. This is due to missing or incorrect nonce validation on the 'speedsize_clear_css_cache_action' function. This makes it possible for unauthenticated attackers to clear the plugins cache via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- SpeedSize Image & Video AI-Optimizer: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: SpeedSize Image & Video AI-Optimizer 1.5.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3236368%40speedsize-ai-image-optimizer&new=3236368%40speedsize-ai-image-optimizer&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1404c675-49b3-48a5-8aac-826c58755b8e?source=cve
Get alerted when CVE-2024-13438 or the next vulnerability affects your stack