What’s Vulnerable › Vulnerabilities
CVE-2024-13440: Super Store Finder <= 7.0 - Unauthenticated SQL Injection to Stored Cross-Site Scripting
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-09 · updated 2026-06-17
- Weakness: CWE-89
Description
The Super Store Finder plugin for WordPress is vulnerable to SQL Injection via the ‘ssf_wp_user_name’ parameter in all versions up to, and including, 7.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into an already existing query to store cross-site scripting in store reviews.
Affected products
- highwarden Super Store Finder: before 7.1 — fixed in 7.1
How to fix
Upgrade to a fixed version: highwarden Super Store Finder 7.1. Check the vendor advisory for mitigations.
References
- https://superstorefinder.net/support/forums/topic/super-store-finder-for-wordpress-patch-notes/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cc468bfd-b9a2-4fe6-b896-d738c767146a?source=cve
Get alerted when CVE-2024-13440 or the next vulnerability affects your stack