What’s Vulnerable › Vulnerabilities
CVE-2024-13441: Bilingual Linker <= 2.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Bilingual Linker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the bl_otherlang_link_1 parameter in all versions up to, and including, 2.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- jackdewey Bilingual Linker: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: jackdewey Bilingual Linker 2.4.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/bilingual-linker/tags/2.4/bilingual-linker.php#L291
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3228519%40bilingual-linker&new=3228519%40bilingual-linker&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/daeda8d7-1bff-4258-9953-b4303f1778d0?source=cve
Get alerted when CVE-2024-13441 or the next vulnerability affects your stack