What’s Vulnerable › Vulnerabilities
CVE-2024-13446: Workreap <= 3.2.5 - Unauthenticated Privilege Escalation via Account Takeover
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-288
Description
The Workreap plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 3.2.5. This is due to the plugin not properly validating a user's identity prior to (1) performing a social auto-login or (2) updating their profile details (e.g. password). This makes it possible for unauthenticated attackers to (1) login as an arbitrary user if their email address is known or (2) change an arbitrary user's password, including administrators, and leverage that to gain access to their account. NOTE: This vulnerability was partially fixed in version 3.2.5.
Affected products
- Workreap: before 3.2.6 — fixed in 3.2.6
How to fix
Upgrade to a fixed version: Workreap 3.2.6. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/workreap-freelance-marketplace-wordpress-theme/23712454
- https://www.wordfence.com/threat-intel/vulnerabilities/id/78c1308b-0849-4235-b2d6-0b1750a5614f?source=cve
Get alerted when CVE-2024-13446 or the next vulnerability affects your stack