What’s Vulnerable › Vulnerabilities
CVE-2024-13449: Boom Fest <= 2.2.1 - Missing Authorization to Authenticated (Subscriber+) Plugin Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The Boom Fest plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'bf_admin_action' function in all versions up to, and including, 2.2.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update plugin settings that change the appearance of the website.
Affected products
- ibsofts Boom Fest: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: ibsofts Boom Fest 2.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/boom-fest/trunk/admin/class-boom-fest-admin.php#L174
- https://plugins.trac.wordpress.org/changeset/3227296/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/246a66ea-7f2f-44e6-825b-5556eacc33ab?source=cve
Get alerted when CVE-2024-13449 or the next vulnerability affects your stack