What’s Vulnerable › Vulnerabilities
CVE-2024-13455: igumbi Online Booking <= 1.40 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The igumbi Online Booking plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'igumbi_calendar' shortcode in all versions up to, and including, 1.40 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- smtm igumbi Online Booking: before 1.41 — fixed in 1.41
How to fix
Upgrade to a fixed version: smtm igumbi Online Booking 1.41. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3243431%40igumbi-online-booking&new=3243431%40igumbi-online-booking&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b21f9cfa-8113-42bc-a9dc-4d891bd9821b?source=cve
Get alerted when CVE-2024-13455 or the next vulnerability affects your stack