What’s Vulnerable › Vulnerabilities
CVE-2024-13472: WooCommerce Product Table Lite <= 3.9.4 - Unauthenticated Arbitrary Shortcode Execution & Reflected Cross-Site Scripting
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-31 · updated 2026-06-17
- Weakness: CWE-94
Description
The The WooCommerce Product Table Lite plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 3.9.4. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The same 'sc_attrs' parameter is vulnerable to Reflected Cross-Site Scripting as well.
Affected products
- WC Product Table WooCommerce Product Table Lite: before 3.9.5 — fixed in 3.9.5
How to fix
Upgrade to a fixed version: WC Product Table WooCommerce Product Table Lite 3.9.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wc-product-table-lite/trunk/main.php#L1843
- https://plugins.trac.wordpress.org/changeset/3231930/
- https://wordpress.org/plugins/wc-product-table-lite/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4f1a1171-3d7b-46a4-982e-fe318e3017b7?source=cve
Get alerted when CVE-2024-13472 or the next vulnerability affects your stack