What’s Vulnerable › Vulnerabilities
CVE-2024-13495: GamiPress <= 7.2.1 - Unauthenticated Arbitrary Shortcode Execution via gamipress_ajax_get_logs Function
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-94
Description
The The GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress plugin for WordPress is vulnerable to arbitrary shortcode execution via the gamipress_ajax_get_logs() function in all versions up to, and including, 7.2.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Affected products
- rubengc GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress: before 7.2.2 — fixed in 7.2.2
How to fix
Upgrade to a fixed version: rubengc GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress 7.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/gamipress/trunk/includes/ajax-functions.php#L39
- https://plugins.trac.wordpress.org/changeset/3226227/
- https://wordpress.org/plugins/gamipress/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/55fa8423-9a41-4afe-9401-03d232caa656?source=cve
Get alerted when CVE-2024-13495 or the next vulnerability affects your stack