What’s Vulnerable › Vulnerabilities
CVE-2024-13509: WS Form LITE and PRO <= 1.10.13 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WS Form LITE and PRO plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the url parameter in all versions up to, and including, 1.10.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability is partially fixed in 1.10.13 and completely fixed in 1.10.14.
Affected products
- westguard WS Form LITE – Drag & Drop Contact Form Builder: before 1.10.14 — fixed in 1.10.14
How to fix
Upgrade to a fixed version: westguard WS Form LITE – Drag & Drop Contact Form Builder 1.10.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3225862/ws-form
- https://plugins.trac.wordpress.org/changeset/3226595/ws-form
- https://wsform.com/changelog/?utm_source=wp_plugins&utm_medium=readme
- https://www.wordfence.com/threat-intel/vulnerabilities/id/910d9b31-b63a-427e-830b-a4c6a7e77ade?source=cve
Get alerted when CVE-2024-13509 or the next vulnerability affects your stack