What’s Vulnerable › Vulnerabilities
CVE-2024-13523: MemorialDay <= 1.0.4 - Cross-Site Request Forgery to Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The MemorialDay plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.4. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- shenyanzhi MemorialDay: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: shenyanzhi MemorialDay 1.1.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3232363%40memorialday%2Ftrunk&old=3207291%40memorialday%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/96cec16e-7bb3-4279-8c17-eca88d413ad8?source=cve
Get alerted when CVE-2024-13523 or the next vulnerability affects your stack