What’s Vulnerable › Vulnerabilities
CVE-2024-13528: Customer Email Verification for WooCommerce <= 2.9.5 - Authentication Bypass via Shortcode
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-287
Description
The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 2.9.5. This is due to the presence of a shortcode that will generate a confirmation link with a placeholder email. This makes it possible for authenticated attackers, with Contributor-level access and above, to generate a verification link for any unverified user and log into the account. The 'Fine tune placement' option must be enabled in the plugin settings in order to exploit the vulnerability.
Affected products
- wpcodefactory Customer Email Verification for WooCommerce: before 2.9.6 — fixed in 2.9.6
How to fix
Upgrade to a fixed version: wpcodefactory Customer Email Verification for WooCommerce 2.9.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/emails-verification-for-woocommerce/tags/2.9.2/includes/class-alg-wc-ev-emails.php#L151
- https://plugins.trac.wordpress.org/changeset/3238136/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0b3798e3-45fe-4829-9012-dc728d4af87f?source=cve
Get alerted when CVE-2024-13528 or the next vulnerability affects your stack