What’s Vulnerable › Vulnerabilities
CVE-2024-13558: NP Quote Request for WooCommerce <= 1.9.179 - Insecure Direct Object Reference to Unauthenticated Sensitive Information Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-639
Description
The NP Quote Request for WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.9.179 due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to read the content of quote requests.
Affected products
- gplsaver NP Quote Request for WooCommerce: before 1.9.180 — fixed in 1.9.180
How to fix
Upgrade to a fixed version: gplsaver NP Quote Request for WooCommerce 1.9.180. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3256816/
- https://wordpress.org/plugins/woo-rfq-for-woocommerce/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5991c86b-6785-41a6-a5df-c65e8a28201c?source=cve
Get alerted when CVE-2024-13558 or the next vulnerability affects your stack