What’s Vulnerable › Vulnerabilities
CVE-2024-13564: Rife Elementor Extensions & Templates <= 1.2.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Writing Effect Headline Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Rife Elementor Extensions & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Writing Effect Headline shortcode in all versions up to, and including, 1.2.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Apollo13 Rife Elementor Extensions & Templates: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: Apollo13 Rife Elementor Extensions & Templates 1.2.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3244081
- https://wordpress.org/plugins/rife-elementor-extensions/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/520555b4-35e8-4ec1-85b8-3a43b5209661?source=cve
Get alerted when CVE-2024-13564 or the next vulnerability affects your stack