What’s Vulnerable › Vulnerabilities
CVE-2024-13571: Post Timeline < 2.3.10 - Reflected XSS
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Timeline WordPress plugin before 2.3.10 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- Post Timeline: before 2.3.10 — fixed in 2.3.10
How to fix
Upgrade to a fixed version: Post Timeline 2.3.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13571 or the next vulnerability affects your stack