What’s Vulnerable › Vulnerabilities
CVE-2024-13575: Web Stories Enhancer – Level Up Your Web Stories <= 1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Web Stories Enhancer – Level Up Your Web Stories plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'web_stories_enhancer' shortcode in all versions up to, and including, 1.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- magazine3 Web Stories Enhancer – Level Up Your Web Stories: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: magazine3 Web Stories Enhancer – Level Up Your Web Stories 1.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/web-stories-enhancer/trunk/includes/shortcode.php#L99
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3238312%40web-stories-enhancer&new=3238312%40web-stories-enhancer&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fdc614f2-37a6-474a-828a-1f34f98715c5?source=cve
Get alerted when CVE-2024-13575 or the next vulnerability affects your stack