What’s Vulnerable › Vulnerabilities
CVE-2024-13587: Zigaform – Price Calculator & Cost Estimation Form Builder Lite <= 7.4.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Zigaform – Price Calculator & Cost Estimation Form Builder Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'zgfm_fvar' shortcode in all versions up to, and including, 7.4.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- softdiscover Zigaform – Price Calculator & Cost Estimation Form Builder Lite: before 7.4.8 — fixed in 7.4.8
How to fix
Upgrade to a fixed version: softdiscover Zigaform – Price Calculator & Cost Estimation Form Builder Lite 7.4.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3241538%40zigaform-calculator-cost-estimation-form-builder-lite&new=3241538%40zigaform-calculator-cost-estimation-form-builder-lite&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0946fab3-6299-4f62-9664-c0a049e2dbb3?source=cve
Get alerted when CVE-2024-13587 or the next vulnerability affects your stack