What’s Vulnerable › Vulnerabilities
CVE-2024-1360: Colibri WP <= 1.0.94 - Cross-Site Request Forgery to Limited Plugin Installation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-23 · updated 2026-06-17
- Weakness: CWE-352
Description
The Colibri WP theme for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.94. This is due to missing or incorrect nonce validation on the colibriwp_install_plugin() function. This makes it possible for unauthenticated attackers to install recommended plugins via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- extendthemes Colibri WP: before 1.1.101 — fixed in 1.1.101
How to fix
Upgrade to a fixed version: extendthemes Colibri WP 1.1.101. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/changeset/218308/colibri-wp/1.0.101/inc/src/PluginsManager.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/db56844f-9988-4f6a-ba1d-f190ff009f2b?source=cve
- https://themes.trac.wordpress.org/changeset/218308/colibri-wp/1.0.101/inc/src/PluginsManager.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/db56844f-9988-4f6a-ba1d-f190ff009f2b?source=cve
Get alerted when CVE-2024-1360 or the next vulnerability affects your stack