What’s Vulnerable › Vulnerabilities
CVE-2024-13600: Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin <= 1.0.5 - Unauthenticated Sensitive Information Exposure Through Unprotected Directory
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-200
Description
The Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.0.5 via the 'majesticsupportdata' directory. This makes it possible for unauthenticated attackers to extract sensitive data stored insecurely in the /wp-content/uploads/majesticsupportdata directory which can contain file attachments included in support tickets.
Affected products
- ahmadmj Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: ahmadmj Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin 1.0.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/majestic-support/tags/1.0.5/includes/classes/uploads.php
- https://plugins.trac.wordpress.org/changeset/3231938/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c5a8fd90-49dd-4a5e-88f2-cd6b338da2d6?source=cve
Get alerted when CVE-2024-13600 or the next vulnerability affects your stack