What’s Vulnerable › Vulnerabilities
CVE-2024-13601: Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin <= 1.0.5 - Authenticated (Subscriber+) Insecure Direct Object Reference
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-639
Description
The Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.0.5 via the 'exportusereraserequest' function due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to export ticket data for any user.
Affected products
- ahmadmj Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: ahmadmj Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin 1.0.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/majestic-support/tags/1.0.5/modules/gdpr/controller.php#L110
- https://plugins.trac.wordpress.org/changeset/3231938/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ebf5537d-d80e-4844-8ed4-480f4a533439?source=cve
Get alerted when CVE-2024-13601 or the next vulnerability affects your stack