What’s Vulnerable › Vulnerabilities
CVE-2024-13615: Social Media Plugin by Social Snap <= 1.3.6 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Share Buttons, Social Sharing Icons, Click to Tweet — Social Media Plugin by Social Snap WordPress plugin through 1.3.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Social Share Buttons, Social Sharing Icons, Click to Tweet — Social Media Plugin by Social Snap: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: Social Share Buttons, Social Sharing Icons, Click to Tweet — Social Media Plugin by Social Snap 1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e8401973-f4c2-4ccf-a6ad-507dde8d2259/
- https://wpscan.com/vulnerability/e8401973-f4c2-4ccf-a6ad-507dde8d2259/
Get alerted when CVE-2024-13615 or the next vulnerability affects your stack